Important Update EURR, USDR

Incident Report for Bit2Me

Update

Actualización — 25 de junio de 2026

Compartimos la última comunicación oficial publicada por StablR Ltd. en relación con el incidente de ciberseguridad. La suspensión del minting y la redención de EURR y USDR se mantiene como medida de precaución. StablR confirma que no se han producido nuevas emisiones no autorizadas desde que se detectó el problema. La investigación sigue activa, coordinada con la Autoridad regulatoria (MFSA de Malta) y especialistas externos, en cumplimiento de MiCAR y DORA.

Puntos clave:
- Suspensión preventiva mantenida: El minting y la redención de EURR y USDR continúan suspendidos. No se han producido emisiones no autorizadas adicionales desde la detección del incidente.
- Investigación activa: Los trabajos se llevan a cabo de forma diligente y en estrecha coordinación con la Autoridad y con especialistas externos, conforme a las obligaciones de StablR bajo MiCAR y DORA. StablR no facilitará detalles del incidente mientras la investigación permanezca abierta.
- Alerta ante fraudes: StablR avisa a los holders de estar atentos ante posibles intentos de fraude. La información oficial se publica exclusivamente en los canales oficiales de StablR. StablR nunca solicitará claves privadas, seed phrases, contraseñas ni pagos de ningún tipo.

Nota de Bit2Me
La gestión de este incidente y la ejecución del plan de recuperación corresponden íntegramente a StablR Ltd., entidad emisora de ambos tokens. La operativa en Bit2Me se reactivará en el momento en que StablR restablezca el servicio de forma segura.
Mantendremos esta página actualizada conforme el emisor publique nueva información oficial.

Gracias por tu paciencia y comprensión.
(Comunicado oficial de StablR: stablr.com / Contacto: info@stablr.com)

---

Update — June 25, 2026

We share the latest official communication published by StablR Ltd. regarding the cybersecurity incident. The suspension of EURR and USDR minting and redemption remains in place as a precautionary measure. StablR confirms that no further unauthorised issuance has occurred since the incident was detected. The investigation remains active, carried out in close coordination with the Authority (MFSA of Malta) and external specialists, consistent with StablR's obligations under MiCAR and DORA.

Key points:
- Precautionary suspension maintained: Minting and redemption of EURR and USDR remain suspended. No further unauthorised issuance has occurred since the incident was detected.
- Active investigation: Work is being carried out diligently and in close coordination with the Authority and external specialists, in keeping with StablR's obligations under MiCAR and DORA. StablR will not share details of the investigation while it remains in progress.
- Fraud alert: StablR urges holders to stay alert to fraud attempts. Official information is published exclusively through StablR's official channels. StablR will never contact holders to request private keys, seed phrases, passwords or payment of any kind.

Bit2Me Note
The management of this incident and the execution of the recovery plan correspond entirely to StablR Ltd., the issuing entity of both tokens. Operations on Bit2Me will be reactivated as soon as StablR safely restores the service.
We will keep this page updated as the issuer publishes new official information.

Thank you for your patience and understanding.
(Official statement from StablR: stablr.com / Contact: info@stablr.com)
Posted Jun 16, 2026 - 10:17 CEST

Update

Compartimos la última actualización oficial emitida por StablR Ltd. en relación con el incidente de ciberseguridad del pasado 24 de mayo. El emisor informa que continúa ejecutando su Plan de Recuperación en colaboración con la Autoridad de Servicios Financieros de Malta (MFSA), siendo la prioridad de la compañía: la protección de los poseedores de tokens, la integridad del proceso de recuperación y la evaluación ordenada de la situación para determinar los próximos pasos.

Puntos clave:
- Operativa suspendida: La emisión, canje, depósitos y retiradas de EURR y USDR se mantienen temporalmente suspendidos en todas las plataformas hasta nuevo aviso.
- Reservas seguras: StablR reitera que los activos de reserva que respaldan ambos tokens siguen estando completamente segregados y protegidos.
- Alerta de seguridad: Se recuerda a los usuarios confiar únicamente en canales oficiales. El emisor nunca solicitará claves privadas, contraseñas ni pagos.

Nota de Bit2Me
La gestión de este incidente y la ejecución del plan de recuperación corresponden íntegramente a StablR Ltd, entidad emisora de ambos tokens. La operativa en Bit2Me se reactivará en el momento en que StablR restablezca el servicio de forma segura.
Mantendremos esta página actualizada conforme el emisor publique nueva información oficial.
Gracias por tu paciencia y comprensión.

(Comunicado oficial de StablR: stablr.com/insights/further-update-concerning-the-cybersecurity-incident-affecting-eurr-usdr / Contacto: info@stablr.com)

--------

We share the latest official update issued by StablR Ltd. regarding the cybersecurity incident detected on May 24th. The issuer reports that it continues to execute its Recovery Plan in collaboration with the Malta Financial Services Authority (MFSA), with the company's priority being: the protection of token holders, the integrity of the recovery process, and the orderly assessment of the situation to determine the next steps.

Key points:
- Suspended operations: The minting, redemption, deposits, and withdrawals of EURR and USDR remain temporarily suspended across all platforms until further notice.
- Secure reserves: StablR reiterates that the reserve assets backing both tokens remain fully segregated and protected.
- Security alert: Users are reminded to rely solely on official channels. The issuer will never request private keys, passwords, or payments.

Bit2Me Note
The management of this incident and the execution of the recovery plan correspond entirely to StablR Ltd, the issuing entity of both tokens. Operations on Bit2Me will be reactivated as soon as StablR safely restores the service.
We will keep this page updated as the issuer publishes new official information.
Thank you for your patience and understanding.

(Official statement from StablR: stablr.com/insights/further-update-concerning-the-cybersecurity-incident-affecting-eurr-usdr / Contact: info@stablr.com)
Posted Jun 05, 2026 - 12:39 CEST

Update

En relación con la suspensión temporal de la operativa de EURR y USDR comunicada el pasado 25 de mayo, compartimos la última actualización oficial emitida por el emisor de estos activos, StablR Ltd.
StablR ha comunicado la activación formal de su Plan de Recuperación tras el incidente de ciberseguridad detectado el 24 de mayo, en coordinación con la Malta Financial Services Authority (MFSA) y bajo el marco regulatorio MiCAR.

Puntos clave del comunicado de StablR:
- Operativa suspendida. Las actividades de emisión, canje, depósitos y retiradas de EURR y USDR permanecen temporalmente suspendidas por orden del emisor en todas las plataformas.
- Fondos respaldados e intactos. StablR indica que todos los activos de reserva que respaldan ambos tokens se encuentran en cuentas segregadas y fondos monetarios independientes. Según los análisis actuales del emisor, el incidente no ha afectado a las reservas.
- Investigación en curso. Especialistas externos en ciberseguridad continúan trabajando para determinar el alcance completo del incidente en la infraestructura de StablR.

Nota de Bit2Me
La gestión de este incidente y la ejecución del plan de recuperación corresponden íntegramente a StablR Ltd, entidad emisora de ambos tokens. La operativa en Bit2Me se reactivará en el momento en que StablR restablezca el servicio de forma segura.
Mantendremos esta página actualizada conforme el emisor publique nueva información oficial.
Gracias por tu paciencia y comprensión.

(Comunicado oficial de StablR: stablr.com/insights/stablr-discloses-cybersecurity-incident-affecting-usdr-and-eurr-token-operations )

--------

In relation to the temporary suspension of EURR and USDR operations announced on May 25th, we are sharing the latest official update issued by the asset creator, StablR Ltd.
StablR has announced the formal activation of its Recovery Plan following the cybersecurity incident detected on May 24th, in coordination with the Malta Financial Services Authority (MFSA) and under the MiCAR regulatory framework.

Key points from StablR's statement:
- Operations suspended. Minting, redemption, deposit, and withdrawal activities for EURR and USDR remain temporarily suspended across all platforms by order of the issuer.
- Funds backed and intact. StablR indicates that all reserve assets backing both tokens are held in segregated accounts and independent money market funds. According to the issuer's current analysis, the incident has not affected these reserves.
- Ongoing investigation. External cybersecurity specialists continue to work on determining the full scope of the incident within StablR's infrastructure.

Note from Bit2Me
The management of this incident and the execution of the recovery plan are entirely the responsibility of StablR Ltd, the issuing entity of both tokens. Operations on Bit2Me will resume as soon as StablR safely restores its service.
We will keep this page updated as the issuer releases new official information.
Thank you for your patience and understanding.

(Official statement from StablR: stablr.com/insights/stablr-discloses-cybersecurity-incident-affecting-usdr-and-eurr-token-operations )
Posted Jun 03, 2026 - 12:37 CEST

Monitoring

La operativa de EURR y USDR está temporalmente suspendida por un incidente externo en el proveedor del activo. Reactivaremos en cuanto confirmemos que la situación está resuelta.

--------

EURR and USDR operations are temporarily suspended due to an external incident with the asset provider. We will reactivate as soon as we confirm that the situation is resolved.
Posted May 25, 2026 - 12:35 CEST